Crear portchannels entre unos 2960 y un nexus

Para configurar dos portchannels que haran de troncales entre un stack con dos 2960 y dos nexus (que no estan en stack).

El dibujo es algo parecido a esto …

cisco 2960 nexus 2012

Los dos 2960 estan conectados con el cable de stack asi que hacemos el portchannel con un puerto de cada switch.
La configuración quedaria asi …

En el NX1:

int port-channel 1
description to 2960_1
speed 1000 (Ojo con la velocidad del interface)
switchport mode trunk
spanning-tree port type network
logging event port link-status
logging event port trunk-status
!

interface Ethernet1/9
description to 2960_1_0_25
no spanning-tree guard root
no link debounce
logging event port link-status
logging event port trunk-status
udld aggressive
channel-group 1 mode passive

!
interface Ethernet1/10
description to 2960_2_0_25
no spanning-tree guard root
no link debounce
logging event port link-status
logging event port trunk-status
udld aggressive
channel-group 1 mode passive

En el 2960_1

interface Port-channel3
description to NX1
switchport
switchport mode trunk
switchport nonegotiate

int Gi1/0/25
description NX1_eth_9
switchport mode trunk
switchport nonegotiate
carrier-delay msec 0
udld port aggressive
channel-group 3 mode active

int Gi1/0/26
description NX1_eth_10
switchport mode trunk
switchport nonegotiate
carrier-delay msec 0
udld port aggressive
channel-group 3 mode active

y listo… lo raro es que si pones los 4 puertos con el mismo modo de chanel-group no rula los del nexus tienen que estar en pasivo y los del 2960 en activo …

¿Alguien podria explicarme porqué?

Ademas ojo con la velocidad de los puertos en el nexus, se supone que los transceivers son de giga y el puerto admite hasta 10 Gb. Si no lo fuerzas no funciona …

Comments are closed.