Enrutamiento entre VRF’s

Aunque me sigue pareciendo raro hablar de “enrutamiento” a nivel 2, hay veces que es necesario “rutar” trafico entre varias VRF’s, se pueden dar dos casos, el primero es que no haya solapamiento ip y el segundo (el mas normal) es que se solapen las ips, en cuyo caso tendremos que hacer NAT.

Vamos a ver la configuración del primer caso (sin solapamiento).
Supongamos dos clientes con su correspondiente vrf para cada uno.
Cliente1: 172.16.1.0/24
Cliente1: 172.16.2.0/24
Cliente2: 172.16.3.0/24
Cliente2: 172.16.4.0/24
Necesitamos que el cliente1 alcance maquinas de las redes del cliente2.
La configuración quedaría asi:
ip vrf01
descripcion la vrf del cliente1
rd 1000:1000
ip vrf02
description la vrf del cliente2
rd: 2000:2000
ip access-list extended vrf-A
permit ip 172.16.1.0 0.0.0.255 172.16.3.0 0.0.0.255
permit ip 172.16.2.0 0.0.0.255 172.16.4.0 0.0.0.255
route map VRF-A
match ip address VRF-A
set vrf vrf02

interface vlan10
description interface vfr-A lan
ip address 172.16.1.1 255.255.255.0
ip policy route-map VRF-A
ip vrf receive vrf02
interface gix/x/10
description interface wan para vfr-A
ip address 192.168.1.1 255.255.255.252
ip policy route-map VRF-A
ip vrf receive vfr02

Eso habilita la comunicación en un solo sentido, para hacerlo en el otro hay que invertir las vrf’s.

Comments are closed.