Fatal error: Database::require() [function.Database-require]: Cannot redeclare class queryconditioninterface

Un daño colateral de la instalación que hice ayer por la noche del APC. Resulta que solo falla en drupal 7, en la versión 6 va bien.


Para solucionarlo hay que cambiar…

apc.include_once_override = 1

en vez de

apc.include_once_override = 0

en el fichero /etc/php5/apache2/php.ini

Según la documentación de php es una función experimental que “optimiza las llamadas a include_once y require_once y evita las caras llamadas al sistema utilizadas.”

Pues el experimento no ha salido bien, así que toca desactivarlo.

Comments are closed.