Old school otra vez de moda

Ahora que el old school y todo lo retro vuelve a estar de moda, la gente vuelve a los colores chillones de los 80, las converse all stars no pasan de moda, pero, lamentablemente para algunos, el wordperfect 5.1 si, y por mucho que lo intenten no va a volver (y eso que era muy comodo).


Todo esto viene porque encontre estas fotos de una visita a una de nuestras oficinas (no es de ahora, puede que tengan un par de años) y recorde la charla que tuvimos un compañero y yo con “la persona” que queria colocarle este cacharro a un pobre becario…
portatil viejo
Tuvimos que convencerle de que, lo mejor que podía hacer es tirar eso a la basura, o mejor aun, llevarlo a un punto limpio para que lo reciclen.
portatil viejo
Que si, que es un portatil, pero ya no sirve para nada, ya sabemos que en su dia te costo una pasta, pero yo creo que esta mas que amortizado. Que pretendes hacer a estas alturas de la vida con un 8086 … ?.
Se le podra poner un ubuntu ??. Mejor ni pensarlo.
Mientras que nos partiamos de risa con las fotos, me llamó un compañero (curioso, aqui somos compañeros cuando “ellos” tienen un problema, pero cuando lo tengo yo si te he visto no me acuerdo) con un problema extraño (no por el problema, sino por la solución que le dimos).
Tiene una maquina con una debian que manda correos (sendmail), los manda sin problemas a todos los sitios. De repente deja de mandar correos a su dirección corporativa que, casualmente esta administrada por alguien que tiene en la mesa de enfrente y esta montado en un W3k con Echange.
Coño, si tu no has tocado nada (el de la debian) y tu compañero si que ha tocado (el del exchange), la solución esta clara, no ?.
Pues no, como casi siempre, nos encontramos con alguien del club de “yo no se que pasa, pero tampoco pienso mirarlo”. El rollo es que, cuando el correo se mandaba al servidor, al hacer ehlo el servidor intentaba utilizar TLS (que no esta configurado) y cascaba. Ahora bien, porque por la mañana funcionaba y por la tarde no?. Vaya usted a saber.
Para forzar que sendmail utilice helo en vez de ehlo hay que cambiar la siguiente linea dentro del fichero de configuración (/etc/mail/sendmail.cf).
Mesmtp, P=[IPC], F=mDFMuXa, S=EnvFromSMTP/HdrFromSMTP -> Cambiar por F=mDFMuX2 Reiniciamos el demonio y punto.
Ahora a por otra chapuza mas…

Comments are closed.