Problema con la consola de Stonegate

Ya me ha pasado varias veces, por alguna extraña razón el servicio “Stonegate Management Server” se para sin dar ningun error, lo arrancas y no te deja entrar. De hecho, cada vez que intentas entrar te da el error y luego se para.

He estado intentando encontrar el error y nada, el único mensaje de error que aparece en el log (eventviewer- appication )es “The description for Event ID ( 0 ) in Source ( PostgreSQL ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Is server running?” sobre el servicio Postgresql, vamos que no ayuda nada.

La unica solución que he encontrado es la siguiente:
Te bajas la última versión de la consola, la descomprimes y empiezas la instalación, uno de los primeros pasos te pregunta si quieres hacer un backup del management server, lo haces y lo mueves a otro sitio (el backup esta en c:\stonesoft\stonegate\backups). Paras la instalación.

Desinstalas la consola (add/remove progams), reinicias.

Instalas la consola de nuevo, compruebas que entras con el usuario que has creado. Paras el servicio, “Stonegate Management Server”, arrancas el script “Restore Management Server Backup” y restauras el backup que has creado 10 min antes.

Arrancas el servicio y ya esta.

Alguien sabe otra forma “mas elegante” de hacerlo?. A mi me ha pasado con versiones 3.x y 4.x de la consola.

Comments are closed.