Problemas con credenciales y proxy pac

Esto de aprender a golpes … a veces no es tan divertido como parece … aunque otras si … Estamos teniendo problemas con la autenticación IWA del puto proxy.

Todavía no tengo claro que sea problema del IWA, yo diría que es problema de la maquina y del cambio de credenciales … Me explico.

Navegadores configurados con el automatic detect settings marcado y use automatic configuration script activado con una cadena como esta: http://x.x.x.x:8080/accelerated_pac_base.pac

Lo de tener las dos activadas es porque… cuando arrancas un cliente vpn de cisco el automatic detect deja de funcionar (por lo que he podido averiguar es porque el cliente de cisco “supone” que tienes acceso directo a internet).

El caso es que, a algunos usuarios, cuando entrar a la vpn y se van a descargar el pac les da un error de autenticacion …

Access Denied (authentication_failed)

Your credentials could not be authenticated: “Credentials are missing.”. You will not be permitted access until your credentials can be verified.

from: x.x.x.x
to: [none] http://x.x.x.x:8080/accelerated_pac_base.pac
proxy: proxy1
2012-08-17 08:50:55

Por alguna extraña razón, al conectar el puto túnel, se pierden las credenciales de la maquina (que son las que autentican).

He creado una regla para hacer un bypass de la autenticacion para esta url en concreto … y funciona … lo cual me deja flipado … no tiene credenciales para bajarse el pac pero si para navegar ??. ¿De donde las saca?.

autenticacion bluecoat

autenticacion bluecoat

Funcionar … funciona … pero no lo veo nada claro … estoy buscando en el foro y en la knowledge base … pero nada. Supongo que se podría hacer con uno de los PermitAuthenticationError1 … pero no doy con el así que … de momento se va a quedar asi.

2 Comments

  • Problemas con credenciales y proxy pac
    Es posible que hayas cambiado la version de sistema del bluecoat y no hayas actualizado el paquete de autenticacion IWA?.

    Navegar con la regla que has creado, es normal, ya que tiene prioridad sobre la navegacion autenticada (esta por encima de esta).

    Mira tambien si en el cliente vpn de cisco, tienes hablitada una ruta para que cuando se lance el tunel, envie todo el trafico por aqui, y deje de encontrar la direccion del archivo .pac.

    Espero haberte dado alguna idea. Es lo que se me ha ocurrido al leer tu post.

    Saludo. Angel.

    • Gracias por la respuesta
      Gracias por la respuesta, todavía no se muy bien lo que pasa. No se ha cambiado la versión. Reiniciando los windows clientes funcionaban (casi todos, a alguno le costó mas de uno) …